summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/files/digest1
-rwxr-xr-xnet-misc/openssh/files/sshd44
-rw-r--r--net-misc/openssh/openssh-2.1.1p4.ebuild44
3 files changed, 89 insertions, 0 deletions
diff --git a/net-misc/openssh/files/digest b/net-misc/openssh/files/digest
new file mode 100644
index 000000000000..3eab6281f5bd
--- /dev/null
+++ b/net-misc/openssh/files/digest
@@ -0,0 +1 @@
+MD5 9525a5a130470290b4adba1f58a7ca8b openssh-2.1.1p4.tar.gz
diff --git a/net-misc/openssh/files/sshd b/net-misc/openssh/files/sshd
new file mode 100755
index 000000000000..a9427815d1a1
--- /dev/null
+++ b/net-misc/openssh/files/sshd
@@ -0,0 +1,44 @@
+#!/bin/sh
+#RCUPDATE:2 3 4:75:This line is required for script management
+
+. /etc/rc.d/config/functions
+
+SERVICE="Secure Shell"
+opts="start stop restart"
+
+PIDFILE=/var/run/sshd.pid
+EXE=/usr/sbin/sshd
+
+start() {
+
+ if [ ! -e /etc/ssh/ssh_host_key ] ; then
+ einfo "Generate Hostkey..."
+ /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N ''
+ fi
+
+ if [ ! -e /etc/ssh/ssh_host_dsa_key ] ; then
+ einfo "Generate DSA-Hostkey..."
+ /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N ''
+ fi
+
+ ebegin "Starting $SERVICE..."
+ start-stop-daemon --start --quiet --exec $EXE
+ eend $? "Started $SERVICE." "Error Starting $SERVICE."
+}
+
+stop() {
+ ebegin "Stopping $SERVICE..."
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $EXE
+ eend $? "Stopped $SERVICE." "Error Stopping $SERVICE."
+}
+
+restart() {
+
+ stop
+ start
+
+}
+
+doservice ${@}
+
+
diff --git a/net-misc/openssh/openssh-2.1.1p4.ebuild b/net-misc/openssh/openssh-2.1.1p4.ebuild
new file mode 100644
index 000000000000..12464b05b3b1
--- /dev/null
+++ b/net-misc/openssh/openssh-2.1.1p4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.1.1p4.ebuild,v 1.1 2000/08/09 22:58:29 achim Exp $
+
+P=openssh-2.1.1p4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Port of OpenBSD's free SSH release"
+CATEGORY=net-misc
+SRC_URI="ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/"${A}
+HOMEPAGE="http://www.openssh.com/"
+
+src_compile() {
+ ./configure --prefix=/usr --sysconfdir=/etc/ssh \
+ --libexecdir=/usr/libexec --mandir=/usr/man \
+ --enable-gnome-askpass \
+ --with-tcp-wrappers --with-ipv4-default --host=${CHOST}
+ make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# patch -p0 < contrib/chroot.diff
+}
+
+src_install() {
+ make manpages install-files DESTDIR=${D}
+ prepman
+ dodoc ChangeLog COPYING.* CREDITS OVERVIEW README* TODO UPGRADING
+ dodir /etc/rc.d/init.d/
+ cp ${O}/files/sshd ${D}/etc/rc.d/init.d/sshd
+}
+
+pkg_config() {
+
+ # Make ssh start at boot
+ echo "Generating symlinks"
+ ${ROOT}/usr/sbin/rc-update add sshd
+
+}
+
+