summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/stunnel/stunnel-3.24.ebuild')
-rw-r--r--net-misc/stunnel/stunnel-3.24.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/stunnel/stunnel-3.24.ebuild b/net-misc/stunnel/stunnel-3.24.ebuild
new file mode 100644
index 000000000000..66d20b1d75dd
--- /dev/null
+++ b/net-misc/stunnel/stunnel-3.24.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-3.24.ebuild,v 1.1 2003/06/28 22:16:20 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TLS/SSL - Port Wrapper"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+HOMEPAGE="http://www.stunnel.org/"
+DEPEND="virtual/glibc >=dev-libs/openssl-0.9.6c"
+RDEPEND=">=dev-libs/openssl-0.9.6c"
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-blinding.fix
+}
+
+src_compile() {
+ econf || die
+# ./configu --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dosbin stunnel
+ dodoc FAQ README HISTORY COPYING BUGS PORTS TODO transproxy.txt
+ doman stunnel.8
+ dolib.so stunnel.so
+}