summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/dchub/dchub-0.5.2.ebuild')
-rw-r--r--net-p2p/dchub/dchub-0.5.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-p2p/dchub/dchub-0.5.2.ebuild b/net-p2p/dchub/dchub-0.5.2.ebuild
new file mode 100644
index 000000000000..c8c956c55a6f
--- /dev/null
+++ b/net-p2p/dchub/dchub-0.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dchub/dchub-0.5.2.ebuild,v 1.1 2004/07/05 17:38:59 squinky86 Exp $
+
+IUSE=""
+
+HOMEPAGE="http://ac2i.homelinux.com/dctc/#dchub"
+DESCRIPTION="dchub (Direct Connect Hub), a linux hub for the p2p 'direct connect'"
+SRC_URI="http://ac2i.homelinux.com/dctc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="virtual/libc
+ =dev-libs/glib-1*
+ dev-lang/perl
+ dev-db/edb"
+
+src_install() {
+ make DESTDIR=${D} install || die "install problem"
+
+ dodoc Documentation/*
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+ dodir /etc/{conf,init}.d /etc/dchub
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dchub.init.d dchub
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dchub.conf.d dchub
+}