summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gtk-gnutella/gtk-gnutella-0.95.4-r1.ebuild')
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.95.4-r1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.95.4-r1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.95.4-r1.ebuild
deleted file mode 100644
index 6c8014e18336..000000000000
--- a/net-p2p/gtk-gnutella/gtk-gnutella-0.95.4-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.95.4-r1.ebuild,v 1.6 2006/02/07 02:56:59 agriffis Exp $
-
-inherit eutils
-
-IUSE="gnome nls"
-
-DESCRIPTION="A GTK+ Gnutella client"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-RESTRICT="nomirror"
-HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ppc sparc x86"
-
-DEPEND="dev-libs/libxml2
- =dev-libs/glib-2* =x11-libs/gtk+-2*
- dev-util/yacc
- nls? ( >=sys-devel/gettext-0.11.5 )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- local myconf
-
- if use nls; then
- myconf="${myconf} -Dd_enablenls -Dgmsgfmt=\"/usr/bin/msgfmt\" -Dmsgfmt=\"/usr/bin/msgfmt\""
- else
- myconf="${myconf} -Ud_enablenls"
- fi
-
- ./Configure -d -s -e \
- -Dprefix="/usr" \
- -Dprivlib="/usr/share/gtk-gnutella" \
- -Dccflags="${CFLAGS}" \
- -Dgtkversion=2 \
- ${myconf} \
- -Doptimize=" " \
- -Dofficial="true" || die "Configure failed"
-
- emake || die "Compile failed"
-}
-
-src_install() {
- dodir /usr/bin
- make INSTALL_PREFIX=${D} install || die "Install failed"
- find ${D}/usr/share -type f -exec chmod a-x {} \;
- dodoc AUTHORS ChangeLog README TODO
-
-}
-