summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qtella/qtella-0.5.4.ebuild')
-rw-r--r--net-p2p/qtella/qtella-0.5.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/qtella/qtella-0.5.4.ebuild b/net-p2p/qtella/qtella-0.5.4.ebuild
new file mode 100644
index 000000000000..561764f20670
--- /dev/null
+++ b/net-p2p/qtella/qtella-0.5.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtella/qtella-0.5.4.ebuild,v 1.1 2002/12/08 21:15:35 verwilst Exp $
+inherit kde-base
+
+use kde && need-kde 3
+use kde || DEPEND="$DEPEND >=x11-libs/qt-3*"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/qtella/${P}.tar.gz"
+HOMEPAGE="http://www.qtella.net"
+DESCRIPTION="Excellent QT/KDE Gnutella Client"
+
+SLOT="3"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+
+ local myconfig
+ use kde && kde_src_compile myconf
+ use kde && myconfig="${myconf}"
+ use kde || myconfig="--with-kde=no --prefix=/usr --host=${CHOST} \
+ --with-x --enable-mitshm --with-xinerama --with-qt-dir=${QTDIR} \
+ --enable-mt --disable-debug --without-debug"
+ ./configure ${myconfig} || die
+ emake || die
+}