summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/gutenprint/files')
-rw-r--r--net-print/gutenprint/files/gutenprint-5.1.7-parallel-build.patch41
-rw-r--r--net-print/gutenprint/files/gutenprint-5.2.3-CFLAGS.patch24
-rw-r--r--net-print/gutenprint/files/gutenprint-5.2.3-parallel-build.patch42
3 files changed, 107 insertions, 0 deletions
diff --git a/net-print/gutenprint/files/gutenprint-5.1.7-parallel-build.patch b/net-print/gutenprint/files/gutenprint-5.1.7-parallel-build.patch
new file mode 100644
index 000000000000..1e8a6d377797
--- /dev/null
+++ b/net-print/gutenprint/files/gutenprint-5.1.7-parallel-build.patch
@@ -0,0 +1,41 @@
+To avoid parallel build issues, the ppd-stamp-pre target has to be executed
+before other ppd targets.
+
+2009-03-04 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/254008
+Index: gutenprint-5.1.7/src/cups/Makefile.am
+===================================================================
+--- gutenprint-5.1.7.orig/src/cups/Makefile.am
++++ gutenprint-5.1.7/src/cups/Makefile.am
+@@ -173,10 +173,11 @@ all-local: $(INSTALL_DATA_LOCAL_DEPS)
+ ppd: ppd-stamp
+
+ ppd-stamp: cups-genppdconfig.@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@ cups-genppd.@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@ $(top_srcdir)/src/main/printers.xml $(top_srcdir)/src/main/papers.xml
++ $(MAKE) ppd-stamp-pre
+ $(MAKE) ppd-stamp-phony
+ touch ppd-stamp
+
+-ppd-stamp-phony: ppd-stamp-pre ppd-nonls $(PPD_NLS)
++ppd-stamp-phony: ppd-nonls $(PPD_NLS)
+
+ ppd-stamp-pre:
+ -$(RM) -r ppd
+Index: gutenprint-5.1.7/src/cups/Makefile.in
+===================================================================
+--- gutenprint-5.1.7.orig/src/cups/Makefile.in
++++ gutenprint-5.1.7/src/cups/Makefile.in
+@@ -1042,10 +1042,11 @@ all-local: $(INSTALL_DATA_LOCAL_DEPS)
+ ppd: ppd-stamp
+
+ ppd-stamp: cups-genppdconfig.@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@ cups-genppd.@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@ $(top_srcdir)/src/main/printers.xml $(top_srcdir)/src/main/papers.xml
++ $(MAKE) ppd-stamp-pre
+ $(MAKE) ppd-stamp-phony
+ touch ppd-stamp
+
+-ppd-stamp-phony: ppd-stamp-pre ppd-nonls $(PPD_NLS)
++ppd-stamp-phony: ppd-nonls $(PPD_NLS)
+
+ ppd-stamp-pre:
+ -$(RM) -r ppd
diff --git a/net-print/gutenprint/files/gutenprint-5.2.3-CFLAGS.patch b/net-print/gutenprint/files/gutenprint-5.2.3-CFLAGS.patch
new file mode 100644
index 000000000000..e5d64e6042e0
--- /dev/null
+++ b/net-print/gutenprint/files/gutenprint-5.2.3-CFLAGS.patch
@@ -0,0 +1,24 @@
+diff -Naur gutenprint-5.2.3-orig/configure.ac gutenprint-5.2.3/configure.ac
+--- gutenprint-5.2.3-orig/configure.ac 2008-12-20 18:04:24.000000000 -0600
++++ gutenprint-5.2.3/configure.ac 2009-02-13 18:52:19.000000000 -0600
+@@ -631,20 +631,6 @@
+ if test x${USE_MAINTAINER_MODE} = xyes ; then
+ STP_ADD_COMPILER_ARGS([-pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
+ fi
+- if test x$ENABLE_DEBUG = xyes ; then
+- STP_ADD_COMPILER_ARG([-g])
+- else
+- STP_ADD_FIRST_COMPILER_ARG([-O6 -O3 -O2 -O1 -O])
+- fi
+-else
+- if test x$ENABLE_DEBUG = xyes ; then
+- STP_ADD_COMPILER_ARG([-g])
+- else
+- STP_ADD_FIRST_COMPILER_ARG([-O])
+- fi
+-fi
+-if test x$ENABLE_PROFILE = xyes ; then
+- STP_ADD_COMPILER_ARG([-pg])
+ fi
+ AC_SUBST(GNUCFLAGS)
+
diff --git a/net-print/gutenprint/files/gutenprint-5.2.3-parallel-build.patch b/net-print/gutenprint/files/gutenprint-5.2.3-parallel-build.patch
new file mode 100644
index 000000000000..20cb10bcbe26
--- /dev/null
+++ b/net-print/gutenprint/files/gutenprint-5.2.3-parallel-build.patch
@@ -0,0 +1,42 @@
+To avoid parallel build issues, the ppd-stamp-pre target has to be executed
+before other ppd targets.
+
+2009-03-04 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/254008
+
+Index: gutenprint-5.2.3/src/cups/Makefile.am
+===================================================================
+--- gutenprint-5.2.3.orig/src/cups/Makefile.am
++++ gutenprint-5.2.3/src/cups/Makefile.am
+@@ -182,10 +182,11 @@ all-local: $(INSTALL_DATA_LOCAL_DEPS)
+ ppd: ppd-stamp
+
+ ppd-stamp: cups-genppd.@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@ $(top_srcdir)/src/xml/xml-stamp
++ $(MAKE) ppd-stamp-pre
+ $(MAKE) ppd-stamp-phony
+ touch ppd-stamp
+
+-ppd-stamp-phony: ppd-stamp-pre $(PPD)
++ppd-stamp-phony: $(PPD)
+
+ ppd-stamp-pre:
+ -$(RM) -r ppd
+Index: gutenprint-5.2.3/src/cups/Makefile.in
+===================================================================
+--- gutenprint-5.2.3.orig/src/cups/Makefile.in
++++ gutenprint-5.2.3/src/cups/Makefile.in
+@@ -1087,10 +1087,11 @@ all-local: $(INSTALL_DATA_LOCAL_DEPS)
+ ppd: ppd-stamp
+
+ ppd-stamp: cups-genppd.@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@ $(top_srcdir)/src/xml/xml-stamp
++ $(MAKE) ppd-stamp-pre
+ $(MAKE) ppd-stamp-phony
+ touch ppd-stamp
+
+-ppd-stamp-phony: ppd-stamp-pre $(PPD)
++ppd-stamp-phony: $(PPD)
+
+ ppd-stamp-pre:
+ -$(RM) -r ppd