summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/gnash/gnash-0.7.2.ebuild')
-rw-r--r--net-www/gnash/gnash-0.7.2.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-www/gnash/gnash-0.7.2.ebuild b/net-www/gnash/gnash-0.7.2.ebuild
index 0713194ef9de..b3dafc212c50 100644
--- a/net-www/gnash/gnash-0.7.2.ebuild
+++ b/net-www/gnash/gnash-0.7.2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2.ebuild,v 1.2 2006/11/18 20:52:55 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2.ebuild,v 1.3 2006/11/21 11:56:41 genstef Exp $
-inherit nsplugins
+inherit nsplugins kde-functions
+set-kdedir
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
@@ -11,7 +12,7 @@ SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 -sparc ~x86 ~ppc"
-IUSE="agg gstreamer ffmpeg nsplugin xml video_cards_i810"
+IUSE="agg gstreamer ffmpeg kde nsplugin xml video_cards_i810"
#dmalloc, broken see bug 142939
#dmalloc? ( dev-libs/dmalloc )
# $(use_enable dmalloc) \
@@ -47,6 +48,7 @@ RDEPEND="
>x11-libs/gtk+-2
x11-libs/pango
!agg? ( virtual/opengl x11-libs/gtkglext )
+ kde? ( kde-base/kdelibs )
agg? ( x11-libs/agg )"
#cairo? ( x11-libs/cairo )
@@ -80,13 +82,12 @@ src_compile() {
myconf="${myconf} --with-mp3-decoder=ffmpeg"
fi
- # klash is broken, thus we do not offer it
econf \
$(use_enable nsplugin plugin) \
$(use_enable xml) \
$(use_enable video_cards_i810 i810-lod-bias) \
--without-gcc-arch \
- --disable-klash \
+ $(use_enable kde klash) \
${myconf} || die "econf failed"
emake || die "emake failed"
}