summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon/ChangeLog7
-rw-r--r--net-www/galeon/files/galeon-1.2.6-to-printpreview.patch15
-rw-r--r--net-www/galeon/galeon-1.2.6.ebuild14
3 files changed, 31 insertions, 5 deletions
diff --git a/net-www/galeon/ChangeLog b/net-www/galeon/ChangeLog
index 0ecee66dd58d..e020f6c6fc2e 100644
--- a/net-www/galeon/ChangeLog
+++ b/net-www/galeon/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-www/galeon
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.21 2002/09/16 04:20:15 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.22 2002/09/20 12:38:08 spider Exp $
*galeon-1.2.6 (16 Sep 2002)
+ 20 Sep 2002; Spider <spider@gentoo.org> galeon-1.2.6.ebuild:
+ Added a patch to make it build with mozilla 1.0.1 and not 1.0. Also changed
+ the dependencies for this.
+
+
16 Sep 2002; Bruce A. Locke <blocke@shivan.org> galeon-1.2.6.ebuild:
Version bump, recommended gcc 3.2 ./configure fix, and unneeded patch
removal. Note: This does not fix the upstream bug involving crashes
diff --git a/net-www/galeon/files/galeon-1.2.6-to-printpreview.patch b/net-www/galeon/files/galeon-1.2.6-to-printpreview.patch
new file mode 100644
index 000000000000..e8c12fb962eb
--- /dev/null
+++ b/net-www/galeon/files/galeon-1.2.6-to-printpreview.patch
@@ -0,0 +1,15 @@
+diff -urw galeon-1.2.6/src/mozilla/GaleonWrapper.cpp galeon-1.2.6-spd/src/mozilla/GaleonWrapper.cpp
+--- galeon-1.2.6/src/mozilla/GaleonWrapper.cpp Thu Sep 5 01:00:26 2002
++++ galeon-1.2.6-spd/src/mozilla/GaleonWrapper.cpp Fri Sep 20 14:08:40 2002
+@@ -182,11 +182,7 @@
+ }
+ else
+ {
+-#if MOZILLA_SNAPSHOT > 1
+ result = print->PrintPreview(options, nsnull, nsnull);
+-#else
+- result = print->PrintPreview(options);
+-#endif
+ }
+
+ return result;
diff --git a/net-www/galeon/galeon-1.2.6.ebuild b/net-www/galeon/galeon-1.2.6.ebuild
index 3a2c90d25681..ec0b6bcbbf90 100644
--- a/net-www/galeon/galeon-1.2.6.ebuild
+++ b/net-www/galeon/galeon-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.6.ebuild,v 1.1 2002/09/16 04:20:16 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.6.ebuild,v 1.2 2002/09/20 12:38:08 spider Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
@@ -13,8 +13,7 @@ SLOT="0"
# This version of galeon supports multiple versions. We are allowing only
# mozilla 1.1-r1 and 1.2a at this time.
-DEPEND=">=net-www/mozilla-1.1-r1
- <=net-www/mozilla-1.2a
+DEPEND=">=net-www/mozilla-1.0.1
>=gnome-base/gnome-libs-1.4.1.4
<=gnome-base/libglade-0.99.0
=gnome-base/gnome-vfs-1.0*
@@ -43,9 +42,16 @@ pkg_setup() {
fi
}
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/galeon-1.2.6-to-printpreview.patch
+}
+
+
src_compile() {
- local myconf=""
+ local myconf="--with-mozilla-snapshot=1.0"
use nls || myconf="${myconf} --disable-nls"
# use bonobo && myconf="${myconf} --enable-gnome-file-selector"