summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/threadlock/threadlock-2.13.0.ebuild')
-rw-r--r--net-zope/threadlock/threadlock-2.13.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/net-zope/threadlock/threadlock-2.13.0.ebuild b/net-zope/threadlock/threadlock-2.13.0.ebuild
deleted file mode 100644
index ef40f1fa5e58..000000000000
--- a/net-zope/threadlock/threadlock-2.13.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/threadlock/threadlock-2.13.0.ebuild,v 1.3 2011/01/13 22:27:49 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="ThreadLock"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Special ThreadLock objects used in Zope2."
-HOMEPAGE="http://pypi.python.org/pypi/ThreadLock"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-RDEPEND="net-zope/extensionclass"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES.txt README.txt"
-PYTHON_MODNAME="${MY_PN}"
-
-distutils_src_test_pre_hook() {
- local module
- for module in ThreadLock; do
- ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
- done
-}
-
-src_install() {
- distutils_src_install
- python_clean_installation_image
-}