summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/allpathslg/allpathslg-35725-r1.ebuild')
-rw-r--r--sci-biology/allpathslg/allpathslg-35725-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/allpathslg/allpathslg-35725-r1.ebuild b/sci-biology/allpathslg/allpathslg-35725-r1.ebuild
new file mode 100644
index 000000000000..e0d302533393
--- /dev/null
+++ b/sci-biology/allpathslg/allpathslg-35725-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpathslg/allpathslg-35725-r1.ebuild,v 1.1 2011/01/27 16:23:34 weaver Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/boost
+ >=sys-devel/gcc-4.3.3
+ sci-biology/vaal"
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ einstall || die
+ # Provided by sci-biology/vaal
+ for i in QueryLookupTable ScaffoldAccuracy MakeLookupTable Fastb ShortQueryLookup; do
+ rm "${D}/usr/bin/$i" || die
+ done
+}