summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/orpie/orpie-1.4.3-r1.ebuild')
-rw-r--r--sci-calculators/orpie/orpie-1.4.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-calculators/orpie/orpie-1.4.3-r1.ebuild b/sci-calculators/orpie/orpie-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..86dd8a161c33
--- /dev/null
+++ b/sci-calculators/orpie/orpie-1.4.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/orpie-1.4.3-r1.ebuild,v 1.1 2006/11/02 00:10:38 ribosome Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A fullscreen RPN calculator for the console"
+HOMEPAGE="http://www.eecs.umich.edu/~pelzlpj/orpie/"
+SRC_URI="http://www.eecs.umich.edu/~pelzlpj/orpie/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="~dev-lang/ocaml-3.08.4
+ sci-libs/gsl
+ sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-quote-down-crash.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D}
+ dodoc ChangeLog
+ dodoc doc/TODO
+ insinto /usr/share/doc/${PF}
+ doins doc/manual.pdf
+ doins doc/manual.html
+}