summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/amd/files/amd-2.2.0-autotools.patch')
-rw-r--r--sci-libs/amd/files/amd-2.2.0-autotools.patch103
1 files changed, 103 insertions, 0 deletions
diff --git a/sci-libs/amd/files/amd-2.2.0-autotools.patch b/sci-libs/amd/files/amd-2.2.0-autotools.patch
new file mode 100644
index 000000000000..13a1e4109f40
--- /dev/null
+++ b/sci-libs/amd/files/amd-2.2.0-autotools.patch
@@ -0,0 +1,103 @@
+diff -Nur ../AMD.orig/configure.ac ./configure.ac
+--- ../AMD.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ ./configure.ac 2007-08-18 16:31:52.575954410 +0100
+@@ -0,0 +1,14 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(amd, 2.2.0, davis@cise.ufl.edu)
++AC_CONFIG_SRCDIR([Source/amd_global.c])
++AC_CONFIG_HEADER([config.h])
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_F77
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CONFIG_FILES([Source/Makefile
++ Demo/Makefile
++ Makefile])
++AC_OUTPUT
+diff -Nur ../AMD.orig/Demo/Makefile.am ./Demo/Makefile.am
+--- ../AMD.orig/Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Demo/Makefile.am 2007-08-18 17:58:28.566755030 +0100
+@@ -0,0 +1,44 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++LDADD = $(top_builddir)/Source/libamd.la -lm
++check_PROGRAMS = \
++ amd_simple \
++ amd_demo \
++ amd_demo2 \
++ amd_l_demo \
++ amd_f77demo \
++ amd_f77simple \
++ amd_f77cross
++
++amd_demo_SOURCES = amd_demo.c
++amd_l_demo_SOURCES = amd_l_demo.c
++amd_demo2_SOURCES = amd_demo2.c
++amd_simple_SOURCES = amd_simple.c
++amd_f77demo_SOURCES = amd_f77demo.f
++
++amd_f77demo_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
++amd_f77simple_SOURCES = amd_f77simple.f
++amd_f77simple_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
++amd_f77wrapper_CPPFLAGS = -DDINT
++amd_f77cross_SOURCES = amd_f77cross.f amd_f77wrapper.f
++amd_f77cross_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo " ----------" ; \
++ ./$$i$(EXEEXT) > my_$$i.out; \
++ diff my_$$i.out $(srcdir)/$$i.out > /dev/null; \
++ if test "x$$?" = "x0"; then \
++ echo "Test $$i PASSED."; \
++ else \
++ echo "** Test $$i FAILED. Diff: "; \
++ diff my_$$i.out $(srcdir)/$$i.out; \
++ doexit="yes"; \
++ fi; \
++ done; \
++ echo " ----------" ; \
++ if test "x$$doexit" = "xyes"; then \
++ exit 1; \
++ fi
++
++clean-local:
++ -rm -f my_*.out
+diff -Nur ../AMD.orig/Makefile.am ./Makefile.am
+--- ../AMD.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Makefile.am 2007-08-18 14:20:51.230268114 +0100
+@@ -0,0 +1,3 @@
++SUBDIRS = Demo Source
++EXTRA_DIST = README.txt
++include_HEADERS = Include/amd.h Include/amd_internal.h
+diff -Nur ../AMD.orig/Source/Makefile.am ./Source/Makefile.am
+--- ../AMD.orig/Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Source/Makefile.am 2007-08-18 16:32:15.237245803 +0100
+@@ -0,0 +1,26 @@
++AMDCSRC = \
++ amd_1.c \
++ amd_2.c \
++ amd_aat.c \
++ amd_control.c \
++ amd_defaults.c \
++ amd_dump.c \
++ amd_info.c \
++ amd_order.c \
++ amd_postorder.c \
++ amd_post_tree.c \
++ amd_preprocess.c \
++ amd_valid.c
++
++lib_LTLIBRARIES = libamd.la libamdf77.la
++noinst_LTLIBRARIES = libamdi.la libamdl.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++libamdi_la_SOURCES = $(AMDCSRC)
++libamdi_la_CPPFLAGS = $(AM_CPPFLAGS) -DDINT
++libamdl_la_SOURCES = $(AMDCSRC)
++libamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++libamd_la_SOURCES = amd_global.c
++libamd_la_LIBADD = libamdl.la libamdi.la
++libamdf77_la_SOURCES = amd.f amdbar.f