summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/btf/btf-1.1.0.ebuild')
-rw-r--r--sci-libs/btf/btf-1.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/btf/btf-1.1.0.ebuild b/sci-libs/btf/btf-1.1.0.ebuild
new file mode 100644
index 000000000000..6f66f86d16db
--- /dev/null
+++ b/sci-libs/btf/btf-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/btf/btf-1.1.0.ebuild,v 1.1 2009/11/21 06:59:44 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_PN=BTF
+DESCRIPTION="Algorithm for matrix permutation into block triangular form"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/btf"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="sci-libs/ufconfig"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog
+}