summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch')
-rw-r--r--sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch35
1 files changed, 20 insertions, 15 deletions
diff --git a/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch b/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch
index 692d3d197e9c..d019b1360e13 100644
--- a/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch
+++ b/sci-libs/cholmod/files/cholmod-1.6.0-autotools.patch
@@ -1,6 +1,6 @@
--- configure.ac 1970-01-01 01:00:00.000000000 +0100
-+++ configure.ac 2008-02-01 19:12:59.582510299 +0000
-@@ -0,0 +1,137 @@
++++ configure.ac 2008-03-28 11:20:10.017415063 +0000
+@@ -0,0 +1,142 @@
+# -*- Autoconf -*-
+AC_PREREQ(2.59)
+AC_INIT(cholmod, 1.6.0, davis@cise.ufl.edu)
@@ -16,42 +16,42 @@
+ [build the check module])],
+ [mod_check=$enableval],
+ [mod_check="yes"])
-+AC_MSG_RESULT($mod_check)
++AC_MSG_RESULT([Enabling mod-check: $mod_check])
+
+AC_ARG_ENABLE(mod-cholesky,
+ [AC_HELP_STRING([--enable-mod-cholesky],
+ [build the cholesky module])],
+ [mod_cholesky=$enableval],
+ [mod_cholesky="yes"])
-+AC_MSG_RESULT($mod_cholesky)
++AC_MSG_RESULT([Enabling mod-cholesku: $mod_cholesky])
+
+AC_ARG_ENABLE(mod-partition,
+ [AC_HELP_STRING([--enable-mod-partition],
+ [build the partition module])],
+ [mod_partition=$enableval],
+ [mod_partition="yes"])
-+AC_MSG_RESULT($mod_partition)
++AC_MSG_RESULT([Enabling mod-partition: $mod_partition])
+
+AC_ARG_ENABLE(mod-matrixops,
+ [AC_HELP_STRING([--enable-mod-matrixops],
+ [build the matrixops module])],
+ [mod_matrixops=$enableval],
+ [mod_matrixops="yes"])
-+AC_MSG_RESULT($mod_matrixops)
++AC_MSG_RESULT([Enabling mod-matrixops: $mod_matrixops])
+
+AC_ARG_ENABLE(mod-modify,
+ [AC_HELP_STRING([--enable-mod-modify],
+ [build the modify module])],
+ [mod_modify=$enableval],
+ [mod_modify="yes"])
-+AC_MSG_RESULT($mod_modify)
++AC_MSG_RESULT([Enabling mod-modify: $mod_modify])
+
+AC_ARG_ENABLE(mod-supernodal,
+ [AC_HELP_STRING([--enable-mod-supernodal],
+ [build the supernodal module])],
+ [mod_supernodal=$enableval],
+ [mod_supernodal="yes"])
-+AC_MSG_RESULT($mod_supernodal)
++AC_MSG_RESULT([Enabling mod-supernoda: $mod_supernodal])
+
+if test x$mod_check = xno; then
+ AC_DEFINE(NCHECK)
@@ -69,9 +69,14 @@
+ AC_DEFINE(NPARTITION)
+else
+ MODULES="$MODULES Partition"
-+ AC_CHECK_HEADERS(metis.h)
-+ AC_CHECK_LIB(metis, METIS_NodeND, [], \
-+ [AC_MSG_ERROR([Cannot find libmetis])])
++ PKG_PROG_PKG_CONFIG
++ if test -n "$PKG_CONFIG"; then
++ PKG_CHECK_MODULES([metis], [metis])
++ else
++ AC_CHECK_HEADERS(metis.h)
++ AC_CHECK_LIB(metis, METIS_NodeND, [metis_LIBS=-lmetis], \
++ [AC_MSG_ERROR([Cannot find libmetis])])
++ fi
+
+ AC_CHECK_HEADERS(ccolamd.h)
+ AC_CHECK_LIB(ccolamd, ccolamd_report, [], \
@@ -615,16 +620,16 @@
+ cholmod_core.h \
+ cholmod_io64.h
--- ./Partition/Makefile.am 1970-01-01 01:00:00.000000000 +0100
-+++ ./Partition/Makefile.am 2008-02-01 18:53:12.292468792 +0000
++++ ./Partition/Makefile.am 2008-03-28 11:18:36.527105814 +0000
@@ -0,0 +1,6 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include
++AM_CPPFLAGS = -I$(top_srcdir)/Include @metis_CFLAGS@
+noinst_LTLIBRARIES = libpart.la libpartl.la
+libpart_la_SOURCES = cholmod_camd.c cholmod_csymamd.c cholmod_nesdis.c cholmod_ccolamd.c cholmod_metis.c
+
+libpartl_la_SOURCES = $(libpart_la_SOURCES)
+libpartl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
--- ./Makefile.am 1970-01-01 01:00:00.000000000 +0100
-+++ ./Makefile.am 2008-02-01 18:53:12.288468564 +0000
++++ ./Makefile.am 2008-03-28 11:20:54.705608972 +0000
@@ -0,0 +1,42 @@
+SUBDIRS = Include Demo Core $(MODULES)
+EXTRA_DIST = README.txt
@@ -644,7 +649,7 @@
+if MOD_PARTITION
+PARTITION = $(top_builddir)/Partition/libpart.la \
+ $(top_builddir)/Partition/libpartl.la \
-+ -lmetis -lccolamd -lcamd
++ @metis_LIBS@ -lccolamd -lcamd
+endif
+
+if MOD_MATRIXOPS