summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave/octave-2.1.69.ebuild')
-rw-r--r--sci-mathematics/octave/octave-2.1.69.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-mathematics/octave/octave-2.1.69.ebuild b/sci-mathematics/octave/octave-2.1.69.ebuild
index cfabbd998e18..0ddfbf53910f 100644
--- a/sci-mathematics/octave/octave-2.1.69.ebuild
+++ b/sci-mathematics/octave/octave-2.1.69.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.10 2007/03/16 22:38:28 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.11 2007/11/20 14:46:56 markusle Exp $
inherit flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ppc ~sparc x86"
-IUSE="emacs static readline zlib tetex hdf5 mpi ifc blas"
+IUSE="emacs static readline zlib latex hdf5 mpi ifc blas"
DEPEND="virtual/libc
>=sys-libs/ncurses-5.2-r3
@@ -21,7 +21,7 @@ DEPEND="virtual/libc
>=dev-util/gperf-2.7.2
zlib? ( sys-libs/zlib )
hdf5? ( sci-libs/hdf5 )
- tetex? ( virtual/tetex )
+ latex? ( virtual/latex-base )
x86? ( ifc? ( dev-lang/ifc ) )
blas? ( virtual/blas )
mpi? ( sys-cluster/lam-mpi )
@@ -68,8 +68,8 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
- use tetex && octave-install-doc
+ make install DESTDIR="${D}" || die "make install failed"
+ use latex && octave-install-doc
if use emacs; then
cd emacs
exeinto /usr/bin
@@ -82,11 +82,11 @@ src_install() {
cd ..
fi
dodir /etc/env.d
- echo "LDPATH=/usr/lib/octave-${PV}" > ${D}/etc/env.d/99octave
+ echo "LDPATH=/usr/lib/octave-${PV}" > "${D}"/etc/env.d/99octave
# Fixes ls-R files to remove /var/tmp/portage references.
- sed -i -e "s:${D}::g" ${D}/usr/libexec/${PN}/ls-R || die
- sed -i -e "s:${D}::g" ${D}/usr/share/${PN}/ls-R || die
+ sed -i -e "s:${D}::g" "${D}"/usr/libexec/${PN}/ls-R || die
+ sed -i -e "s:${D}::g" "${D}"/usr/share/${PN}/ls-R || die
}
pkg_postinst() {