summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/pari/pari-2.3.4-r1.ebuild')
-rw-r--r--sci-mathematics/pari/pari-2.3.4-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sci-mathematics/pari/pari-2.3.4-r1.ebuild b/sci-mathematics/pari/pari-2.3.4-r1.ebuild
index c0f20a32ff29..b9ddb9f76f17 100644
--- a/sci-mathematics/pari/pari-2.3.4-r1.ebuild
+++ b/sci-mathematics/pari/pari-2.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.4-r1.ebuild,v 1.9 2010/01/11 22:38:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.4-r1.ebuild,v 1.10 2010/05/04 21:56:09 bicatali Exp $
EAPI=2
inherit elisp-common eutils flag-o-matic toolchain-funcs
@@ -18,7 +18,7 @@ SRC_URI="${SRC_COM}/unix/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="doc data emacs fltk gmp static X"
+IUSE="doc data emacs fltk gmp static-libs X"
RDEPEND="sys-libs/readline
emacs? ( virtual/emacs )
@@ -64,6 +64,7 @@ src_prepare() {
}
src_configure() {
+ append-flags -fno-strict-aliasing
tc-export CC
# need to force optimization here, as it breaks without
if is-flag -O0; then
@@ -94,9 +95,9 @@ src_compile() {
emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn \
|| die "Building shared library failed!"
- if use static; then
+ if use static-libs; then
emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" lib-sta \
- || die "Building static library failed!"
+ || die "Building static-libs library failed!"
fi
emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp \
@@ -142,10 +143,10 @@ src_install() {
emake DESTDIR="${D}" install-data || die "Failed to install data files"
fi
- if use static; then
+ if use static-libs; then
emake \
DESTDIR="${D}" \
- install-lib-sta || die "Install of static library failed"
+ install-lib-sta || die "Install of static-libs library failed"
fi
}