summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/scilab/scilab-3.1.1.ebuild')
-rw-r--r--sci-mathematics/scilab/scilab-3.1.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-mathematics/scilab/scilab-3.1.1.ebuild b/sci-mathematics/scilab/scilab-3.1.1.ebuild
index 2b410bf6bcde..66a6b2015e5e 100644
--- a/sci-mathematics/scilab/scilab-3.1.1.ebuild
+++ b/sci-mathematics/scilab/scilab-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-3.1.1.ebuild,v 1.1 2005/06/21 00:12:24 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-3.1.1.ebuild,v 1.2 2005/06/21 00:32:56 ribosome Exp $
inherit eutils
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.scilab.org/"
LICENSE="scilab"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE="ifc tcltk atlas gtk gtk2 Xaw3d"
+IUSE="ifc ocaml tcltk atlas gtk gtk2 Xaw3d"
RDEPEND="virtual/x11
sys-libs/ncurses
@@ -81,6 +81,9 @@ src_compile() {
use gtk2 && myopts="${myopts} --with-gtk2" || \
myopts="${myopts} --with-gtk"
fi
+ if ! use ocaml; then
+ myopts="${myopts} --without-ocaml"
+ fi
econf ${myopts} || die
env HOME=${S} make all || die