summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/reduce/ChangeLog7
-rw-r--r--sci-mathematics/reduce/Manifest4
-rw-r--r--sci-mathematics/reduce/reduce-20110414.ebuild79
3 files changed, 88 insertions, 2 deletions
diff --git a/sci-mathematics/reduce/ChangeLog b/sci-mathematics/reduce/ChangeLog
index f73778c1a493..e4c2fff29492 100644
--- a/sci-mathematics/reduce/ChangeLog
+++ b/sci-mathematics/reduce/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/reduce
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/ChangeLog,v 1.2 2011/03/29 21:02:40 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/ChangeLog,v 1.3 2011/09/22 11:15:33 grozin Exp $
+
+*reduce-20110414 (22 Sep 2011)
+
+ 22 Sep 2011; Andrey Grozin <grozin@gentoo.org> +reduce-20110414.ebuild:
+ Version bump
*reduce-20101007-r1 (29 Mar 2011)
diff --git a/sci-mathematics/reduce/Manifest b/sci-mathematics/reduce/Manifest
index 64739f2751ac..f1080226c130 100644
--- a/sci-mathematics/reduce/Manifest
+++ b/sci-mathematics/reduce/Manifest
@@ -2,6 +2,8 @@ AUX 64reduce-gentoo.el 215 RMD160 c1ea0ffbb343c45610dc9343b19cf99d49a64ebb SHA1
AUX csl 38 RMD160 8b9bee18834a82c3e0681455c35174385a0d3796 SHA1 5001f02d0d74c8c1c9df83eca8299ec63fd328e6 SHA256 d99f85be4783179534d8c805f839d66b75671caa21516a6ba7497fd9639bd68b
AUX redcsl 41 RMD160 f8f86cdf3625e70a07a406f6e04849fa6b9acdcb SHA1 5ab636dacd8eb732870f2a093b9e87d0a187afc0 SHA256 bd76b9bc8eb3ea6445793db744c5d2833e4f777242996e597f9015ad983ee8ba
DIST reduce-algebra-20101007.tar.bz2 64624533 RMD160 73687191a38fe5db227b031815d84e0710fdec19 SHA1 cce8ebeb0eeaa8baa9ecd229c4ee563672d652ba SHA256 cda53b974b9e16125f4fea823f6fc73d5b6dac4e40dae69e1c22ebb8fa7a1a0f
+DIST reduce-src-20110414.tar.bz2 136783974 RMD160 cd9842fe607b439a8db8daf8083eb2aaa9ac05d7 SHA1 a6c73f5fcaa3efeb1cb9650bb6478d912e3914a1 SHA256 d6ac7a30e817ea71555d21b03a119a5236967b251eae8946a1817ae9a81cee03
EBUILD reduce-20101007-r1.ebuild 2229 RMD160 a09335780de414046b8833a692c7be3cd760093d SHA1 b13796d32016c5e1e652fa425cbb99f7dcef0264 SHA256 5f4c248224c8a9141f5b7ea7f5c17a2bedc5ac6b4c0a0053d3575a6b590f748c
-MISC ChangeLog 683 RMD160 8be221fcc49112563640e2cb2a2046b6e9f6b48b SHA1 bfc7aa2ccc2efc180367d6f3742eb854c834a0f8 SHA256 a113a2cda2f77e1e73597a7ce9a4ac5f95f1ca0ffc7e968def2143eb2068dba2
+EBUILD reduce-20110414.ebuild 2151 RMD160 22e332cc3714897e453d83e33dea430372eabb33 SHA1 7e7e930202ad60275126eaf7bfc6a93cc64091bf SHA256 1a80ecb2e36af574c424914fe146f911d50a94232efae307cf457c1b5fadcdce
+MISC ChangeLog 805 RMD160 d7317e898d773fafe7db717e16858c23d0b6e31f SHA1 c08fb9533bd68ee8c6a69e24874beeca97d1a953 SHA256 95e2e57e3c9eb984323420e08098899f90de50182bfa0e8a568a3e89f03d574b
MISC metadata.xml 381 RMD160 e4e15644314b8ebedf988136c974a4eb06944d55 SHA1 43012cd92b799a81f00cfb715de849f61a9169f0 SHA256 0ab958d614f9d0a5ff87b86bf74ab0ef616bc355757e34f69f1d2f53efbc7d6d
diff --git a/sci-mathematics/reduce/reduce-20110414.ebuild b/sci-mathematics/reduce/reduce-20110414.ebuild
new file mode 100644
index 000000000000..29fb420bdd80
--- /dev/null
+++ b/sci-mathematics/reduce/reduce-20110414.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/reduce-20110414.ebuild,v 1.1 2011/09/22 11:15:33 grozin Exp $
+EAPI=4
+inherit elisp-common
+
+DESCRIPTION="A general-purpose computer algebra system"
+HOMEPAGE="http://reduce-algebra.sourceforge.net/
+ http://reduce-algebra.com/"
+IUSE="doc emacs gnuplot X"
+SRC_URI="mirror://sourceforge/${PN}-algebra/${PN}-src-${PV}.tar.bz2"
+LICENSE="BSD-2 X? ( LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="X? ( x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXft )
+ gnuplot? ( sci-visualization/gnuplot )
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # If you pass --prefix to this damn configure,
+ # make (not make install!) will try to install stuff
+ # into the live file system => sandbox violation
+ # Therefore, I cannot use econf here
+ # Also, make calls configure in maintainer mode in subdirs *by design*
+ # The trunk sucks less => WONTFIX until the next release
+ ./configure --with-csl $(use_with X gui)
+ # psl build requires Internet connection at build time
+ # we cannot support it
+}
+
+src_compile() {
+ emake STRIP=true
+
+ pushd cslbuild/*/csl/reduce.doc > /dev/null
+ rm -f *.txt *.tex
+ popd > /dev/null
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile generic/emacs/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ emake testall || die "emake testall failed"
+}
+
+src_install() {
+ pushd cslbuild/*/csl > /dev/null
+ exeinto /usr/lib/${PN}
+ doexe reduce csl
+ insinto /usr/lib/${PN}
+ doins reduce.img csl.img
+ doins -r reduce.doc
+ if use X; then
+ doins -r reduce.fonts
+ fi
+ popd > /dev/null
+ exeinto /usr/bin
+ doexe "${FILESDIR}/redcsl" "${FILESDIR}/csl"
+ dodoc README BUILDING DEPENDENCY_TRACKING
+ dosym /usr/lib/${PN}/${PN}.doc /usr/share/doc/${PF}/html
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/util/r38.pdf
+ fi
+
+ if use emacs; then
+ pushd generic/emacs > /dev/null
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/64${PN}-gentoo.el"
+ popd > /dev/null
+ fi
+}