summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/oww/oww-0.81.9.ebuild')
-rw-r--r--sci-misc/oww/oww-0.81.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-misc/oww/oww-0.81.9.ebuild b/sci-misc/oww/oww-0.81.9.ebuild
new file mode 100644
index 000000000000..940ed55614d0
--- /dev/null
+++ b/sci-misc/oww/oww-0.81.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/oww/oww-0.81.9.ebuild,v 1.1 2006/11/30 00:02:40 markusle Exp $
+
+DESCRIPTION="A one-wire weather station for Dallas Semiconductor"
+HOMEPAGE="http://oww.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/gtk+-2.6
+ net-misc/curl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:doc/oww:doc/${P}/:" -i Makefile.in || \
+ die "Failed to fix doc install path"
+}
+
+src_compile() {
+ econf --enable-interactive || die "Failed during configure"
+ emake || die "Failed during make."
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "Failed during install."
+}