summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/diffutils/diffutils-2.7.5-r1.ebuild')
-rw-r--r--sys-apps/diffutils/diffutils-2.7.5-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/diffutils/diffutils-2.7.5-r1.ebuild b/sys-apps/diffutils/diffutils-2.7.5-r1.ebuild
new file mode 100644
index 000000000000..865aa4319d01
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.7.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.7.5-r1.ebuild,v 1.1 2002/01/04 17:55:44 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools to make diffs and compare files"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+
+if [ -z "`use build`" ]
+then
+ DEPEND="$DEPEND sys-apps/texinfo"
+fi
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ local myconf=""
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myconf} || die
+
+ if [ "`use build`" ]
+ then
+ #disable texinfo building so we can remove the dep
+ cp Makefile Makefile.orig
+ sed -e 's/^all: ${PROGRAMS} info/all: ${PROGRAMS}/g' \
+ Makefile.orig > Makefile
+ fi
+ emake || die
+
+ if [ -z "`use build`" ]
+ then
+ #fix the info page
+ cp doc/diff.info doc/diff.info.orig
+ sed -e 's/^Diff: (diff)/* Diff: (diff)/' \
+ doc/diff.info.orig > doc/diff.info
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+}
+
+