summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kmod/kmod-6.ebuild')
-rw-r--r--sys-apps/kmod/kmod-6.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/sys-apps/kmod/kmod-6.ebuild b/sys-apps/kmod/kmod-6.ebuild
deleted file mode 100644
index 5964f236248a..000000000000
--- a/sys-apps/kmod/kmod-6.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-6.ebuild,v 1.2 2012/03/09 23:51:10 williamh Exp $
-
-EAPI=4
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
-
-[[ "${PV}" == "9999" ]] && vcs=git-2
-inherit ${vcs} autotools eutils toolchain-funcs
-unset vcs
-
-if [[ "${PV}" != "9999" ]] ; then
- SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="doc debug lzma static-libs +tools zlib"
-
-COMMON_DEPEND="!sys-apps/module-init-tools
- !sys-apps/modutils
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-
-DEPEND="${COMMON_DEPEND}
- doc? ( dev-util/gtk-doc )"
-RDEPEND="${COMMON_DEPEND}"
-
-src_prepare()
-{
- if [ ! -e configure ]; then
- if use doc; then
- gtkdocize --copy --docdir libkmod/docs || die "gtkdocize failed"
- else
- touch libkmod/docs/gtk-doc.make
- fi
- eautoreconf
- else
- elibtoolize
- fi
-}
-
-src_configure()
-{
- econf \
- $(use_enable debug) \
- $(use_enable doc gtk-doc) \
- $(use_with lzma xz) \
- $(use_enable static-libs static) \
- $(use_enable tools) \
- $(use_with zlib)
-}
-
-src_install()
-{
- default
-
- # we have a .pc file for people to use
- find "${D}" -name libkmod.la -delete
-
- if use tools; then
- dodir /bin
-dosym /usr/bin/kmod /bin/lsmod
- dodir /sbin
- for cmd in depmod insmod modinfo modprobe rmmod; do
- dosym /usr/bin/kmod /sbin/$cmd
- done
- fi
-}