summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/logwatch/logwatch-7.1.ebuild')
-rw-r--r--sys-apps/logwatch/logwatch-7.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/logwatch/logwatch-7.1.ebuild b/sys-apps/logwatch/logwatch-7.1.ebuild
new file mode 100644
index 000000000000..d874344c4c44
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-7.1.ebuild,v 1.1 2005/12/10 02:36:34 vapier Exp $
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+SRC_URI="ftp://ftp.kaybee.org/pub/linux/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/cron
+ virtual/mta
+ dev-lang/perl
+ dev-perl/Tie-IxHash
+ dev-perl/Date-Calc
+ virtual/mailx"
+DEPEND=""
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /var/cache/logwatch
+ dodir /etc/logwatch
+
+ newsbin scripts/logwatch.pl logwatch.pl || die "dosbin logwatch failed"
+
+ for i in scripts/logfiles/* ; do
+ exeinto /usr/share/logwatch/$i
+ doexe $i/* || die "doexe $i failed"
+ done
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc project/CHANGES README HOWTO-Make-Filter
+}