summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/lomoco/lomoco-1.0-r1.ebuild')
-rw-r--r--sys-apps/lomoco/lomoco-1.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/lomoco/lomoco-1.0-r1.ebuild b/sys-apps/lomoco/lomoco-1.0-r1.ebuild
new file mode 100644
index 000000000000..702c05134eb8
--- /dev/null
+++ b/sys-apps/lomoco/lomoco-1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lomoco/lomoco-1.0-r1.ebuild,v 1.1 2006/04/30 09:41:33 robbat2 Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Lomoco can configure vendor-specific options on Logitech USB mice \
+(or dual-personality mice plugged into the USB port). Visit the website for \
+specific available options."
+HOMEPAGE="http://lomoco.linux-gamers.net/"
+SRC_URI="http://lomoco.linux-gamers.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libusb"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo-hardware-support.patch
+ cd ${S}
+ eautoreconf
+}
+
+src_compile() {
+ econf
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}