summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/lsof/lsof-4.60.ebuild')
-rw-r--r--sys-apps/lsof/lsof-4.60.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/lsof/lsof-4.60.ebuild b/sys-apps/lsof/lsof-4.60.ebuild
new file mode 100644
index 000000000000..07ebff1f2944
--- /dev/null
+++ b/sys-apps/lsof/lsof-4.60.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Grant Goodyear <g2boojum@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.60.ebuild,v 1.1 2002/01/12 23:27:42 karltk Exp $
+
+#Not a good idea to override ${P}; changed to ${P2}
+P0=lsof_4.60
+#${A} autogenerated from SRC_URI, no need to define here
+S0=${WORKDIR}
+S=${WORKDIR}/${P0}
+DESCRIPTION="Lists open files for running Unix processes"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${P0}_W.tar.gz ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${P0}_W.tar.gz"
+HOMEPAGE="http://"
+
+DEPEND="virtual/glibc virtual/kernel"
+
+#This pkg appears to be highly kernel-dependent.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S0}
+ try tar xvf ${P0}.tar
+}
+
+src_compile() {
+ #interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
+ #is there a way to avoid the "echo to a file + file read"?
+ #Just piping in the results didn't seem to work.
+ echo -e "y\ny\ny\nn\ny\ny\n" > junk
+ #${T} is for temporary stuff. Don't create stray files just anywhere
+ ./Configure linux < junk
+ #simple Makefile hack to insert CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" Makefile.orig > Makefile
+ try make all
+}
+
+src_install () {
+ doman lsof.8
+ #/usr/sbin is a good location -- drobbins
+ dosbin lsof
+ # .a libs not needed during boot so they go in /usr/lib -- drobbins
+ dolib lib/liblsof.a
+ dodoc
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+}
+