summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pciutils/pciutils-3.0.2.ebuild')
-rw-r--r--sys-apps/pciutils/pciutils-3.0.2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/pciutils/pciutils-3.0.2.ebuild b/sys-apps/pciutils/pciutils-3.0.2.ebuild
new file mode 100644
index 000000000000..b5f93751581d
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-3.0.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.0.2.ebuild,v 1.1 2008/10/07 10:13:18 robbat2 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.0-build.patch #233314
+ #epatch "${FILESDIR}"/${PN}-3.0.0-resolv.patch #218555 #Merged
+ epatch "${FILESDIR}"/pcimodules-${PN}-3.0.0.patch
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ epatch "${FILESDIR}"/${PN}-3.0.0-locale-happiness.patch
+ sed -i -e "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+uyesno() { use $1 && echo yes || echo no ; }
+pemake() {
+ emake \
+ DNS="yes" \
+ IDSDIR="/usr/share/misc" \
+ MANDIR="/usr/share/man" \
+ PREFIX="/usr" \
+ SHARED="yes" \
+ STRIP="" \
+ ZLIB=$(uyesno zlib) \
+ "$@"
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ pemake OPT="${CFLAGS}" all pcimodules || die "emake failed"
+}
+
+src_install() {
+ pemake DESTDIR="${D}" install install-lib || die
+ dosbin pcimodules || die
+ newman pcimodules.man pcimodules.8
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+
+ # Install both forms until HAL has migrated
+ if use zlib ; then
+ local sharedir="${D}/usr/share/misc"
+ elog "Providing a backwards compatibility non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+}