summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ucspi-tcp/ucspi-tcp-0.88-r6.ebuild')
-rw-r--r--sys-apps/ucspi-tcp/ucspi-tcp-0.88-r6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r6.ebuild b/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r6.ebuild
new file mode 100644
index 000000000000..cb57d52f373e
--- /dev/null
+++ b/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-tcp/ucspi-tcp-0.88-r6.ebuild,v 1.1 2003/08/13 03:17:11 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+SRC_URI="http://cr.yp.to/${PN}/${P}.tar.gz
+ ipv6? ( http://www.fefe.de/ucspi/ucspi-tcp-0.88-ipv6.diff13.bz2 )
+ ssl? ( http://www.nrg4u.com/qmail/ucspi-tcp-ssl-20020705.patch.gz )
+ mirror://qmail/ucspi-rss.diff"
+HOMEPAGE="http://cr.yp.to/ucspi-tcp.html"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~alpha"
+LICENSE="as-is"
+IUSE="ssl ipv6"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use ipv6; then
+ epatch ${WORKDIR}/ucspi-tcp-0.88-ipv6.diff13
+ elif use ssl; then
+ epatch ${WORKDIR}/ucspi-tcp-ssl-20020705.patch
+ fi
+ epatch ${FILESDIR}/${PV}-errno.patch
+ epatch ${DISTDIR}/ucspi-rss.diff
+
+ echo "${CC} ${CFLAGS}" > conf-cc
+ echo "${CC} ${LDFLAGS}" > conf-ld
+ echo "/usr/" > conf-home
+
+ # allow larger responses
+ sed -i 's|if (text.len > 200) text.len = 200;|if (text.len > 500) text.len = 500;|g' ${S}/rblsmtpd.c
+}
+
+src_compile() {
+ pmake || die
+}
+
+src_install() {
+ dobin tcpserver tcprules tcprulescheck argv0 recordio tcpclient *\@ tcpcat mconnect mconnect-io addcr delcr fixcrio rblsmtpd
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+}