summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub/grub-9999.ebuild')
-rw-r--r--sys-boot/grub/grub-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 246179d87fea..71d3bd4654b9 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.21 2010/07/06 00:33:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.22 2010/07/06 00:41:18 vapier Exp $
# XXX: need to implement a grub.conf migration in pkg_postinst before we ~arch
@@ -81,6 +81,8 @@ src_install() {
if use multislot ; then
sed -i "s:grub-install:grub2-install:" "${D}"/sbin/grub-install || die
mv "${D}"/sbin/grub{,2}-install || die
+ mv "${D}"/sbin/grub{,2}-set-default || die
+ mv "${D}"/usr/share/man/man8/grub{,2}-install.8 || die
mv "${D}"/usr/share/info/grub{,2}.info || die
fi
}