summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild')
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild
index 1774b70220c7..756c615b709f 100644
--- a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild,v 1.8 2013/02/02 23:12:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild,v 1.9 2013/04/29 10:43:43 lxnay Exp $
EAPI=4
@@ -14,9 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND=">=sys-apps/openrc-0.8.2-r1
- !sys-apps/systemd
- "
+DEPEND=">=sys-apps/openrc-0.8.2-r1"
RDEPEND="${DEPEND}
>=sys-boot/plymouth-0.8.3-r5
"
@@ -36,4 +34,9 @@ pkg_postinst() {
einfo "If you'd like to know more about purpose of /run, please read:"
einfo " https://lwn.net/Articles/436012/"
fi
+
+ if has_version sys-apps/systemd; then
+ eerror "sys-apps/systemd is installed, please uninstall this package if you"
+ eerror "are booting with systemd"
+ fi
}