summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/rgmanager/rgmanager-1.02.00-r1.ebuild')
-rw-r--r--sys-cluster/rgmanager/rgmanager-1.02.00-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-cluster/rgmanager/rgmanager-1.02.00-r1.ebuild b/sys-cluster/rgmanager/rgmanager-1.02.00-r1.ebuild
new file mode 100644
index 000000000000..92df481be0e0
--- /dev/null
+++ b/sys-cluster/rgmanager/rgmanager-1.02.00-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/rgmanager/rgmanager-1.02.00-r1.ebuild,v 1.1 2006/07/14 13:32:43 xmerlin Exp $
+
+inherit linux-mod eutils
+
+CVS_RELEASE="20060713"
+CLUSTER_VERSION="1.02.00"
+
+DESCRIPTION="Clustered resource group manager layered on top of Magma"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/cluster-${CLUSTER_VERSION}.tar.gz
+ mirror://gentoo/${PN}-${PV}-${CVS_RELEASE}-cvs.patch.gz
+ http://dev.gentoo.org/~xmerlin/gfs/${PN}-${PV}-${CVS_RELEASE}-cvs.patch.gz"
+
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=sys-cluster/magma-1.02.00-r1
+ >=sys-cluster/magma-plugins-1.02.00-r1
+ dev-libs/libxml2
+ "
+
+S="${WORKDIR}/cluster-${CLUSTER_VERSION}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${PN}-${PV}-${CVS_RELEASE}-cvs.patch || die
+ epatch ${FILESDIR}/${PN}-${PV}-${CVS_RELEASE}-cvs-clunfslock.patch || die
+}
+
+src_compile() {
+ check_KV
+ ./configure --kernel_src=${KERNEL_DIR} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ newinitd ${FILESDIR}/${PN}.rc ${PN} || die
+ newconfd ${FILESDIR}/${PN}.conf ${PN} || die
+}