summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild b/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild
new file mode 100644
index 000000000000..b0747b62271e
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-1.3.ebuild,v 1.1 2004/06/04 07:30:40 dragonheart Exp $
+
+MY_PV="1.3r3"
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha arm hppa amd64 ~ia64 ~ppc64 s390"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin mksquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES
+}