summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/unionfs/unionfs-1.0.8.ebuild')
-rw-r--r--sys-fs/unionfs/unionfs-1.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/unionfs/unionfs-1.0.8.ebuild b/sys-fs/unionfs/unionfs-1.0.8.ebuild
new file mode 100644
index 000000000000..19659e34e138
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.8.ebuild,v 1.1 2005/02/05 14:06:08 genstef Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="acl debug vserver"
+
+MODULE_NAMES="unionfs(fs:)"
+BUILD_TARGETS="all"
+BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+
+src_unpack() {
+ local user_Makefile=fistdev.mk
+ local EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+# use vserver && epatch ${FILESDIR}/${P}-vserver.patch
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DNODEBUG"
+ fi
+ use acl && EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR -DFIST_SETXATTR_CONSTVOID"
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
+}
+
+src_install() {
+ dosbin unionctl uniondbg
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8
+
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README
+}