summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.4.23.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.23.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild
index 2188783854b4..40d195cbe7cb 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild,v 1.14 2004/04/14 22:01:01 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild,v 1.15 2004/06/23 22:49:16 agriffis Exp $
ETYPE="headers"
inherit kernel eutils
@@ -49,7 +49,7 @@ src_unpack() {
# This patch fixes an issue involving the use of gcc's -ansi flag and the __u64 datatype.
# It only patches asm-i386, so we only apply it if x86. Unknown if this is needed for other archs.
# Closes Bug #32246
- if [ -n "`use x86`" ]; then
+ if use x86; then
epatch ${FILESDIR}/${PN}-strict-ansi-fix.patch
fi
@@ -64,7 +64,7 @@ src_compile() {
kernel_src_compile
# If this is sparc, then generate asm_offsets.h
- if [ -n "`use sparc`" ]; then
+ if use sparc; then
make ARCH=${ARCH} dep || die "Failed to run 'make dep'"
fi
}