summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/zen-sources/zen-sources-3.6.9999.ebuild')
-rw-r--r--sys-kernel/zen-sources/zen-sources-3.6.9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/zen-sources/zen-sources-3.6.9999.ebuild b/sys-kernel/zen-sources/zen-sources-3.6.9999.ebuild
new file mode 100644
index 000000000000..64586d8abe65
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-3.6.9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/zen-sources-3.6.9999.ebuild,v 1.1 2012/12/14 19:27:43 hwoarang Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".lzma"
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+# If these are not set, you will get weird behavior from kernel-2, due to the
+# huge $PV that is used otherwise.
+CKV='2.6.99'
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999}/master"
+EGIT_REPO_URI="git://github.com/damentz/zen-kernel.git
+ https://github.com/damentz/zen-kernel.git"
+
+inherit kernel-2 git-2
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="http://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}