summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.3.20040420.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.3.20040420.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
index 6cb1c22f3fdb..14453049ce1f 100644
--- a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.18 2004/07/20 10:59:02 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.19 2004/07/22 00:10:31 mr_bones_ Exp $
inherit eutils flag-o-matic gcc
@@ -254,7 +254,7 @@ src_unpack() {
cd ${S}
# Extract our threads package ...
- if (! use_nptl) && [ -z "${BRANCH_UPDATE}" ]
+ if ! use_nptl && [ -z "${BRANCH_UPDATE}" ]
then
unpack glibc-linuxthreads-${MY_PV}.tar.bz2
fi
@@ -290,7 +290,7 @@ src_unpack() {
# sparc fails when building the components for the normal crt1.o
# with -K PIC automatically via hardened PIE and SSP specs files
- if ( use sparc && use hardened )
+ if use sparc && use hardened
then
einfo "adding crt1.o bugfix for hardened gcc on sparc glibc"
sed -i "s|CPPFLAGS += -DHAVE_INITFINI|CPPFLAGS += -DHAVE_INITFINI -fno-pie -fno-PIE|" \