summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/drupal/drupal-4.6.1.ebuild')
-rw-r--r--www-apps/drupal/drupal-4.6.1.ebuild97
1 files changed, 0 insertions, 97 deletions
diff --git a/www-apps/drupal/drupal-4.6.1.ebuild b/www-apps/drupal/drupal-4.6.1.ebuild
deleted file mode 100644
index dc1cb9aa1923..000000000000
--- a/www-apps/drupal/drupal-4.6.1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-4.6.1.ebuild,v 1.4 2005/07/05 15:10:40 st_lim Exp $
-
-inherit webapp eutils
-
-MY_PV=${PV:0:3}.0
-
-DESCRIPTION="Drupal is a PHP-based open-source platform and content management system for building dynamic web sites offering a broad range of features and services; including user administration, publishing workflow, discussion capabilities, news aggregation, metadata functionalities using controlled vocabularies and XML publishing for content sharing purposes. Equipped with a powerful blend of features and configurability, Drupal can support a diverse range of web projects ranging from personal weblogs to large community-driven sites."
-HOMEPAGE="http://drupal.org"
-IUSE="$IUSE minimal"
-S="${WORKDIR}/${P}"
-
-SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~ppc ~x86"
-
-DEPEND="virtual/php"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack ${P}.tar.gz
-
- if ! use minimal ; then
-
- for i in modules themes engines language; do
- cd ${S}/$i
- [ "$i" == "engines" ] && cd ${S}/themes/$i
- [ "$i" == "language" ] && cd ${S}/includes
- einfo "`pwd`"
- for item in `cat ${FILESDIR}/${MY_PV}/$i`; do
- einfo "Unpacking $item"
- wget -q http://www.drupal.org/files/projects/$item-${MY_PV}.tar.gz
- tar xfz $item-${MY_PV}.tar.gz
- done
- done
-
- find ${S} -name "*.tar.gz" -exec rm -rf {} \;
- find ${S} -type f -exec chmod 644 {} \;
- find ${S} -type d -exec chmod 755 {} \;
- fi
-}
-
-src_compile() {
- #Default compile hangs!
- echo "Nothing to compile"
-}
-
-src_install() {
-
- local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt"
-
- webapp_src_preinst
-
- # handle documentation files
- #
- D# NOTE that doc files go into /usr/share/doc as normal; they do NOT
- # get installed per vhost!
-
- einfo "Installing docs"
- dodoc ${docs}
- for doc in ${docs} INSTALL; do
- rm -f ${doc}
- done
-
- einfo "Copying main files"
- cp -r . ${D}/${MY_HTDOCSDIR}
-
- # we install the .htaccess file to enable support for clean URLs
- cp .htaccess ${D}/${MY_HTDOCSDIR}
-
- # create the files upload directory
- mkdir ${D}/${MY_HTDOCSDIR}/files
- webapp_serverowned ${MY_HTDOCSDIR}/files
-
- # Identify any script files that need #! headers adding to run under
- # a CGI script (such as PHP/CGI)
- #
- # for drupal, we *assume* that all .php files need to have CGI/BIN
- # support added
-
- for x in `find . -name '*.php' -print ` ; do
- webapp_runbycgibin php ${MY_HTDOCSDIR}/$x
- done
-
- #All files must be owned by server
- for x in `find . -type f -print` ; do
- webapp_serverowned ${MY_HTDOCSDIR}/$x
- done
-
- webapp_configfile ${MY_HTDOCSDIR}/sites/default/settings.php
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
-
- webapp_src_install
-}