summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/mythweb/mythweb-0.20.1.ebuild')
-rw-r--r--www-apps/mythweb/mythweb-0.20.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/www-apps/mythweb/mythweb-0.20.1.ebuild b/www-apps/mythweb/mythweb-0.20.1.ebuild
new file mode 100644
index 000000000000..d9deea5eebe9
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.20.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.20.1.ebuild,v 1.1 2007/04/27 06:39:07 cardoe Exp $
+
+inherit mythtv webapp depend.php
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/httpd-php
+ dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+S="${WORKDIR}/mythplugins-${MY_PV}/${PN}"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if has_version 'dev-lang/php' ; then
+ require_php_with_use session mysql pcre posix
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/.."
+ mythtv-fixes_patch
+ cd "${S}"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README TODO
+
+ dodir ${MY_HTDOCSDIR}/data
+
+ cp -R [[:lower:]]* .htaccess ${D}${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/data
+
+ webapp_configfile ${MY_HTDOCSDIR}/.htaccess
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-0.20.txt
+
+ webapp_src_install
+}