summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/galeon/galeon-1.3.18.ebuild')
-rw-r--r--www-client/galeon/galeon-1.3.18.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/www-client/galeon/galeon-1.3.18.ebuild b/www-client/galeon/galeon-1.3.18.ebuild
deleted file mode 100644
index 2b11cb338978..000000000000
--- a/www-client/galeon/galeon-1.3.18.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/galeon-1.3.18.ebuild,v 1.4 2005/07/14 23:33:14 swegener Exp $
-
-inherit gnome2 debug libtool
-
-DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
-HOMEPAGE="http://galeon.sourceforge.net"
-SRC_URI="mirror://sourceforge/galeon/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-IUSE=""
-KEYWORDS="x86 ~ppc alpha sparc amd64 ~ia64"
-SLOT="0"
-
-RDEPEND="virtual/x11
- >=www-client/mozilla-1.7.5
- >=dev-libs/glib-2
- >=x11-libs/gtk+-2.4.0
- >=dev-libs/libxml2-2.6.6
- >=gnome-base/gconf-2.3.2
- >=gnome-base/orbit-2
- >=gnome-base/libbonobo-2
- >=gnome-base/libbonoboui-2.1.1
- >=gnome-base/libgnomeui-2.5.2
- >=gnome-base/gnome-vfs-2
- >=gnome-base/libglade-2.3.1
- app-text/scrollkeeper"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=dev-util/intltool-0.30
- >=sys-devel/gettext-0.11"
-
-pkg_setup () {
- if [ ! -f ${ROOT}/usr/lib/mozilla/components/libwidget_gtk2.so ]
- then
- eerror "you need mozilla-1.4+ compiled against gtk+-2"
- eerror "export USE=\"gtk2\" ;emerge mozilla -p "
- die "Need Mozilla compiled with gtk+-2.0!!"
- fi
-}
-
-src_compile() {
- elibtoolize
-
- local moz_ver="`pkg-config --modversion mozilla-xpcom | cut -d. -f1,2 2>/dev/null`"
- local myconf="--disable-werror"
-
- myconf="${myconf} --with-mozilla-snapshot=${moz_ver}"
-
- econf ${myconf} || die "configure failed"
- make || die "compile failed"
-
-}
-
-DOCS="AUTHORS COPYING COPYING.README ChangeLog FAQ INSTALL README README.ExtraPrefs THANKS TODO NEWS"