summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/phantomjs/phantomjs-1.9.0.ebuild')
-rw-r--r--www-client/phantomjs/phantomjs-1.9.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-client/phantomjs/phantomjs-1.9.0.ebuild b/www-client/phantomjs/phantomjs-1.9.0.ebuild
new file mode 100644
index 000000000000..b8c0e5712f58
--- /dev/null
+++ b/www-client/phantomjs/phantomjs-1.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/phantomjs/phantomjs-1.9.0.ebuild,v 1.1 2013/04/25 19:36:22 zx2c4 Exp $
+
+EAPI=5
+
+DESCRIPTION="A headless WebKit scriptable with a JavaScript API."
+HOMEPAGE="http://phantomjs.org/"
+SRC_URI="https://phantomjs.googlecode.com/files/${P}-source.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="media-libs/fontconfig media-libs/freetype"
+RDEPEND="${DEPEND}"
+
+
+src_prepare() {
+ sed -i 's/# CONFIG += text_breaking_with_icu/CONFIG += text_breaking_with_icu/' \
+ src/qt/src/3rdparty/webkit/Source/JavaScriptCore/JavaScriptCore.pri
+}
+
+src_compile() {
+ ./build.sh --confirm --qt-config $(pkg-config --cflags-only-I freetype2) || die
+}
+
+src_test() {
+ ./bin/phantomjs test/run-tests.js || die
+}
+
+src_install() {
+ dobin bin/phantomjs || die
+ dodoc ChangeLog README.md
+ if use examples ; then
+ docinto examples
+ dodoc examples/* || die
+ fi
+}