summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/webfs/webfs-1.21.ebuild')
-rw-r--r--www-servers/webfs/webfs-1.21.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-servers/webfs/webfs-1.21.ebuild b/www-servers/webfs/webfs-1.21.ebuild
new file mode 100644
index 000000000000..95d597f2de65
--- /dev/null
+++ b/www-servers/webfs/webfs-1.21.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/webfs-1.21.ebuild,v 1.1 2005/02/16 15:58:36 ka0ttic Exp $
+
+DESCRIPTION="Lightweight HTTP server for static content"
+SRC_URI="http://dl.bytesex.org/releases/${PN}/${P}.tar.gz"
+HOMEPAGE="http://linux.bytesex.org/misc/webfs.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
+IUSE="ssl threads"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}
+ app-misc/mime-types"
+
+src_compile() {
+ local myconf
+ use ssl || myconf="${myconf} USE_SSL=no"
+ use threads && myconf="${myconf} USE_THREADS=yes"
+
+ emake prefix=/usr ${myconf} || die "emake failed"
+}
+
+src_install() {
+ einstall mandir=${D}/usr/share/man || die "make install failed"
+ newinitd ${FILESDIR}/${PN}.initd ${PN} || die "newinitd failed"
+ newconfd ${FILESDIR}/${PN}.confd ${PN} || die "newconfd failed"
+ dodoc README COPYING
+}