summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xkbcomp/xkbcomp-1.0.4.ebuild')
-rw-r--r--x11-apps/xkbcomp/xkbcomp-1.0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-apps/xkbcomp/xkbcomp-1.0.4.ebuild b/x11-apps/xkbcomp/xkbcomp-1.0.4.ebuild
new file mode 100644
index 000000000000..2510284b8f11
--- /dev/null
+++ b/x11-apps/xkbcomp/xkbcomp-1.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbcomp/xkbcomp-1.0.4.ebuild,v 1.1 2008/03/10 01:58:56 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib
+
+DESCRIPTION="compile XKB keyboard description"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ x-modular_src_install
+
+ dodir usr/share/X11/xkb
+ dosym ../../../bin/xkbcomp /usr/share/X11/xkb/xkbcomp
+
+ # (#122214) We should create this directory here, since xkeyboard-config
+ # and any other set of layouts will symlink to it.
+ dodir /var/lib/xkb
+ keepdir /var/lib/xkb
+}