summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild')
-rw-r--r--x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
new file mode 100644
index 000000000000..b4ec80edcede
--- /dev/null
+++ b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild,v 1.1 2012/01/09 20:45:53 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
+HOMEPAGE="https://github.com/mgorny/libtinynotify/"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc static-libs"
+
+RDEPEND="sys-apps/dbus"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+DOCS=( README )
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ )
+
+ autotools-utils_src_configure
+}