summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libSM/ChangeLog6
-rw-r--r--x11-libs/libSM/libSM-1.0.2.ebuild8
-rw-r--r--x11-libs/libSM/libSM-1.0.3.ebuild8
-rw-r--r--x11-libs/libSM/libSM-1.1.0.ebuild6
-rw-r--r--x11-libs/libXaw/ChangeLog6
-rw-r--r--x11-libs/libXaw/libXaw-1.0.3.ebuild8
-rw-r--r--x11-libs/libXaw/libXaw-1.0.4.ebuild8
-rw-r--r--x11-libs/libXfont/ChangeLog6
-rw-r--r--x11-libs/libXfont/libXfont-1.3.1-r1.ebuild10
-rw-r--r--x11-libs/libXfont/libXfont-1.3.4.ebuild10
-rw-r--r--x11-libs/libXfont/libXfont-1.4.0.ebuild10
-rw-r--r--x11-libs/libXmu/ChangeLog6
-rw-r--r--x11-libs/libXmu/libXmu-1.0.3.ebuild8
-rw-r--r--x11-libs/libXmu/libXmu-1.0.4.ebuild6
-rw-r--r--x11-libs/libxcb/ChangeLog6
-rw-r--r--x11-libs/libxcb/libxcb-1.1.90.1.ebuild12
-rw-r--r--x11-libs/libxcb/libxcb-1.1.ebuild6
17 files changed, 82 insertions, 48 deletions
diff --git a/x11-libs/libSM/ChangeLog b/x11-libs/libSM/ChangeLog
index 32567876a03a..dcbbc758a333 100644
--- a/x11-libs/libSM/ChangeLog
+++ b/x11-libs/libSM/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libSM
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/ChangeLog,v 1.62 2009/04/16 02:11:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/ChangeLog,v 1.63 2009/05/04 17:01:42 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> libSM-1.0.2.ebuild,
+ libSM-1.0.3.ebuild, libSM-1.1.0.ebuild:
+ Move use_ functions out of global scope.
16 Apr 2009; Jeroen Roovers <jer@gentoo.org> libSM-1.1.0.ebuild:
Stable for HPPA (bug #251832).
diff --git a/x11-libs/libSM/libSM-1.0.2.ebuild b/x11-libs/libSM/libSM-1.0.2.ebuild
index 161eb31bd54f..0c34c68e9317 100644
--- a/x11-libs/libSM/libSM-1.0.2.ebuild
+++ b/x11-libs/libSM/libSM-1.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.0.2.ebuild,v 1.12 2007/08/07 13:04:51 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.0.2.ebuild,v 1.13 2009/05/04 17:01:42 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -17,4 +17,6 @@ RDEPEND="x11-libs/libICE
x11-proto/xproto"
DEPEND="${RDEPEND}"
-CONFIGURE_OPTIONS="$(use_enable ipv6)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}
diff --git a/x11-libs/libSM/libSM-1.0.3.ebuild b/x11-libs/libSM/libSM-1.0.3.ebuild
index ed09b86eb724..94bde2764271 100644
--- a/x11-libs/libSM/libSM-1.0.3.ebuild
+++ b/x11-libs/libSM/libSM-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.0.3.ebuild,v 1.8 2008/01/13 09:23:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.0.3.ebuild,v 1.9 2009/05/04 17:01:42 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -17,4 +17,6 @@ RDEPEND="x11-libs/libICE
x11-proto/xproto"
DEPEND="${RDEPEND}"
-CONFIGURE_OPTIONS="$(use_enable ipv6)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}
diff --git a/x11-libs/libSM/libSM-1.1.0.ebuild b/x11-libs/libSM/libSM-1.1.0.ebuild
index 77e6b1a91f04..cdf5d359e9eb 100644
--- a/x11-libs/libSM/libSM-1.1.0.ebuild
+++ b/x11-libs/libSM/libSM-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.1.0.ebuild,v 1.10 2009/04/16 02:11:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.1.0.ebuild,v 1.11 2009/05/04 17:01:42 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -18,4 +18,6 @@ RDEPEND="x11-libs/libICE
|| ( sys-libs/e2fsprogs-libs sys-fs/e2fsprogs )"
DEPEND="${RDEPEND}"
-CONFIGURE_OPTIONS="$(use_enable ipv6)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}
diff --git a/x11-libs/libXaw/ChangeLog b/x11-libs/libXaw/ChangeLog
index 876b549fa554..557611125de3 100644
--- a/x11-libs/libXaw/ChangeLog
+++ b/x11-libs/libXaw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libXaw
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/ChangeLog,v 1.57 2009/04/16 02:13:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/ChangeLog,v 1.58 2009/05/04 17:03:40 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> libXaw-1.0.3.ebuild,
+ libXaw-1.0.4.ebuild:
+ Move use_ functions out of global scope.
16 Apr 2009; Jeroen Roovers <jer@gentoo.org> libXaw-1.0.5.ebuild:
Stable for HPPA (bug #251832).
diff --git a/x11-libs/libXaw/libXaw-1.0.3.ebuild b/x11-libs/libXaw/libXaw-1.0.3.ebuild
index b2bed4fb5276..690ed990a753 100644
--- a/x11-libs/libXaw/libXaw-1.0.3.ebuild
+++ b/x11-libs/libXaw/libXaw-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/libXaw-1.0.3.ebuild,v 1.11 2007/08/07 13:07:05 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/libXaw-1.0.3.ebuild,v 1.12 2009/05/04 17:03:40 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -21,9 +21,9 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
sys-apps/ed"
-CONFIGURE_OPTIONS="$(use_enable xprint xaw8)"
-
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable xprint xaw8)"
+
# No such function yet
# x-modular_pkg_setup
diff --git a/x11-libs/libXaw/libXaw-1.0.4.ebuild b/x11-libs/libXaw/libXaw-1.0.4.ebuild
index e2cc184cb36e..886413a605ef 100644
--- a/x11-libs/libXaw/libXaw-1.0.4.ebuild
+++ b/x11-libs/libXaw/libXaw-1.0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/libXaw-1.0.4.ebuild,v 1.8 2008/01/13 09:23:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/libXaw-1.0.4.ebuild,v 1.9 2009/05/04 17:03:40 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -21,9 +21,9 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
sys-apps/ed"
-CONFIGURE_OPTIONS="$(use_enable xprint xaw8)"
-
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable xprint xaw8)"
+
# No such function yet
# x-modular_pkg_setup
diff --git a/x11-libs/libXfont/ChangeLog b/x11-libs/libXfont/ChangeLog
index 042a82dad5d2..7c691730b50d 100644
--- a/x11-libs/libXfont/ChangeLog
+++ b/x11-libs/libXfont/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libXfont
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.104 2009/04/29 11:49:55 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.105 2009/05/04 16:59:19 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ libXfont-1.3.1-r1.ebuild, libXfont-1.3.4.ebuild, libXfont-1.4.0.ebuild:
+ Move use_ functions out of global scope.
29 Apr 2009; Rémi Cardona <remi@gentoo.org> -libXfont-1.3.0.ebuild,
-libXfont-1.3.1.ebuild, -libXfont-1.3.2.ebuild, -libXfont-1.3.3.ebuild:
diff --git a/x11-libs/libXfont/libXfont-1.3.1-r1.ebuild b/x11-libs/libXfont/libXfont-1.3.1-r1.ebuild
index 3e0e0c98bbd9..ccbcf6b18355 100644
--- a/x11-libs/libXfont/libXfont-1.3.1-r1.ebuild
+++ b/x11-libs/libXfont/libXfont-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.3.1-r1.ebuild,v 1.9 2008/04/13 22:50:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.3.1-r1.ebuild,v 1.10 2009/05/04 16:59:19 ssuominen Exp $
# Must be before x-modular eclass is inherited
# SNAPSHOT="yes"
@@ -20,14 +20,14 @@ RDEPEND="x11-libs/xtrans
DEPEND="${RDEPEND}
x11-proto/fontcacheproto"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- --with-encodingsdir=/usr/share/fonts/encodings"
-
PATCHES="
${FILESDIR}/0001-Fix-for-CVE-2008-0006-PCF-Font-parser-buffer-overf.patch
"
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
# No such function yet
# x-modular_pkg_setup
diff --git a/x11-libs/libXfont/libXfont-1.3.4.ebuild b/x11-libs/libXfont/libXfont-1.3.4.ebuild
index 4729e16f31ae..18560d4f834b 100644
--- a/x11-libs/libXfont/libXfont-1.3.4.ebuild
+++ b/x11-libs/libXfont/libXfont-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.3.4.ebuild,v 1.8 2009/04/16 02:17:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.3.4.ebuild,v 1.9 2009/05/04 16:59:19 ssuominen Exp $
# Must be before x-modular eclass is inherited
# SNAPSHOT="yes"
@@ -20,11 +20,11 @@ RDEPEND="x11-libs/xtrans
DEPEND="${RDEPEND}
x11-proto/fontcacheproto"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- --with-bzip2
- --with-encodingsdir=/usr/share/fonts/encodings"
-
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-bzip2
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
# No such function yet
# x-modular_pkg_setup
diff --git a/x11-libs/libXfont/libXfont-1.4.0.ebuild b/x11-libs/libXfont/libXfont-1.4.0.ebuild
index e0a9a49ffe7e..3a490af594f4 100644
--- a/x11-libs/libXfont/libXfont-1.4.0.ebuild
+++ b/x11-libs/libXfont/libXfont-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.4.0.ebuild,v 1.1 2009/04/29 11:38:35 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.4.0.ebuild,v 1.2 2009/05/04 16:59:19 ssuominen Exp $
# Must be before x-modular eclass is inherited
# SNAPSHOT="yes"
@@ -20,11 +20,11 @@ RDEPEND="x11-libs/xtrans
DEPEND="${RDEPEND}
x11-proto/fontcacheproto"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- --with-bzip2
- --with-encodingsdir=/usr/share/fonts/encodings"
-
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-bzip2
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
# No such function yet
# x-modular_pkg_setup
diff --git a/x11-libs/libXmu/ChangeLog b/x11-libs/libXmu/ChangeLog
index f584a21efe65..9d07e50d75eb 100644
--- a/x11-libs/libXmu/ChangeLog
+++ b/x11-libs/libXmu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libXmu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXmu/ChangeLog,v 1.47 2009/04/16 02:19:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXmu/ChangeLog,v 1.48 2009/05/04 16:56:32 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> libXmu-1.0.3.ebuild,
+ libXmu-1.0.4.ebuild:
+ Move use_ functions out of global scope.
16 Apr 2009; Jeroen Roovers <jer@gentoo.org> libXmu-1.0.4.ebuild:
Stable for HPPA (bug #251832).
diff --git a/x11-libs/libXmu/libXmu-1.0.3.ebuild b/x11-libs/libXmu/libXmu-1.0.3.ebuild
index 46a81cd6be78..f109ef3d70a1 100644
--- a/x11-libs/libXmu/libXmu-1.0.3.ebuild
+++ b/x11-libs/libXmu/libXmu-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXmu/libXmu-1.0.3.ebuild,v 1.11 2007/08/07 13:12:54 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXmu/libXmu-1.0.3.ebuild,v 1.12 2009/05/04 16:56:32 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -18,4 +18,6 @@ RDEPEND="x11-libs/libXt
x11-proto/xproto"
DEPEND="${RDEPEND}"
-CONFIGURE_OPTIONS="$(use_enable ipv6)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}
diff --git a/x11-libs/libXmu/libXmu-1.0.4.ebuild b/x11-libs/libXmu/libXmu-1.0.4.ebuild
index b4cf24a0a706..82483dc97306 100644
--- a/x11-libs/libXmu/libXmu-1.0.4.ebuild
+++ b/x11-libs/libXmu/libXmu-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXmu/libXmu-1.0.4.ebuild,v 1.8 2009/04/16 02:19:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXmu/libXmu-1.0.4.ebuild,v 1.9 2009/05/04 16:56:32 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -18,4 +18,6 @@ RDEPEND="x11-libs/libXt
x11-proto/xproto"
DEPEND="${RDEPEND}"
-CONFIGURE_OPTIONS="$(use_enable ipv6)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index 806f99023bc1..971b0ea47beb 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.29 2009/02/06 10:48:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.30 2009/05/04 17:06:59 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> libxcb-1.1.ebuild,
+ libxcb-1.1.90.1.ebuild:
+ Move use_ functions out of global scope.
06 Feb 2009; Raúl Porcel <armin76@gentoo.org> libxcb-1.1.ebuild:
arm/ia64/s390/sh stable wrt #244210
diff --git a/x11-libs/libxcb/libxcb-1.1.90.1.ebuild b/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
index 6854ea9b977a..526e997db854 100644
--- a/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
+++ b/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.90.1.ebuild,v 1.1 2008/07/30 22:38:05 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.90.1.ebuild,v 1.2 2009/05/04 17:06:59 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -21,9 +21,11 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
>=x11-proto/xcb-proto-1.2"
-CONFIGURE_OPTIONS="$(use_enable doc build-docs)
- $(use_enable selinux xselinux)
- --enable-xinput"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)
+ $(use_enable selinux xselinux)
+ --enable-xinput"
+}
pkg_postinst() {
x-modular_pkg_postinst
diff --git a/x11-libs/libxcb/libxcb-1.1.ebuild b/x11-libs/libxcb/libxcb-1.1.ebuild
index 8271a916bd21..a4ae04a4f4cd 100644
--- a/x11-libs/libxcb/libxcb-1.1.ebuild
+++ b/x11-libs/libxcb/libxcb-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.ebuild,v 1.10 2009/02/06 10:48:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.ebuild,v 1.11 2009/05/04 17:06:59 ssuominen Exp $
# Must be before x-modular eclass is inherited
SNAPSHOT="yes"
@@ -21,7 +21,9 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
~x11-proto/xcb-proto-${PV}"
-CONFIGURE_OPTIONS="$(use_enable doc build-docs)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)"
+}
pkg_postinst() {
x-modular_pkg_postinst