summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dmenu/dmenu-4.3.1.ebuild')
-rw-r--r--x11-misc/dmenu/dmenu-4.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/dmenu/dmenu-4.3.1.ebuild b/x11-misc/dmenu/dmenu-4.3.1.ebuild
new file mode 100644
index 000000000000..8d08cffbdde1
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-4.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-4.3.1.ebuild,v 1.1 2011/05/31 08:15:38 cedk Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.suckless.org/programs/dmenu.html"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -ansi -pedantic -Wall -Os/CFLAGS += -ansi -pedantic -Wall -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ -e "s/XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ if use xinerama; then
+ emake CC=$(tc-getCC) || die "emake failed"
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" \
+ || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ dodoc README
+}