summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/idesk/idesk-0.5.6.ebuild')
-rw-r--r--x11-misc/idesk/idesk-0.5.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/idesk/idesk-0.5.6.ebuild b/x11-misc/idesk/idesk-0.5.6.ebuild
new file mode 100644
index 000000000000..9a6313b13a7b
--- /dev/null
+++ b/x11-misc/idesk/idesk-0.5.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/idesk-0.5.6.ebuild,v 1.1 2003/07/29 17:18:31 bcowan Exp $
+
+DESCRIPTION="Utility to place icons on the root window"
+HOMEPAGE="http://idesk.timmfin.net"
+SRC_URI="mirror://sourceforge/idesk/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ppc"
+
+DEPEND=">media-libs/imlib-1.9.14
+ virtual/x11
+ media-libs/freetype
+ >=gnome-base/librsvg-2.2.5
+ >=dev-util/pkgconfig-0.12.0
+ dev-libs/libxml2
+ =dev-libs/glib-2*
+ gnome-extra/libgsf
+ =x11-libs/pango-1*
+ =x11-libs/gtk+-2*
+ media-libs/libart_lgpl"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #Allow for more robust CXXFLAGS
+ mv Makefile Makefile.orig
+ sed -e "s:= -g -W #-Wall:= ${CXXFLAGS}:" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe idesk
+ dodoc README
+ doman ${FILESDIR}/idesk.1 ${FILESDIR}/ideskrc.5
+}
+
+pkg_postinst() {
+ einfo
+ einfo "NOTE: Please refer to ${HOMEPAGE}"
+ einfo "NOTE: For info on configuring ${PN}"
+ einfo
+}