summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild')
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
index bc66e8278a3f..ea451075d78d 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild,v 1.1 2010/02/08 18:11:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild,v 1.2 2010/02/08 18:20:05 jer Exp $
+
+EAPI="2"
inherit eutils
@@ -15,30 +17,23 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
SLOT="0"
RDEPEND="x11-libs/libX11
- guile? ( dev-scheme/guile )
+ guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
tk? ( dev-lang/tk )"
DEPEND="${RDEPEND}
x11-proto/xproto"
-pkg_setup() {
- if use guile && has_version ">=dev-scheme/guile-1.8" \
- && ! built_with_use ">=dev-scheme/guile-1.8" deprecated
- then
- eerror "In order to compile xbindkeys with guile-1.8 or higher, you need"
- eerror "to recompile dev-scheme/guile with the \"deprecated\" USE flag."
- die "Please re-emerge dev-scheme/guile with USE=\"deprecated\"."
- fi
-}
-
-src_compile() {
+src_configure() {
local myconf
use tk || myconf="${myconf} --disable-tk"
use guile || myconf="${myconf} --disable-guile"
econf ${myconf} || die "configure failed"
- emake DESTDIR=${D} || die "make failed"
+}
+
+src_compile() {
+ emake DESTDIR="${D}" || die "make failed"
}
src_install() {
- make DESTDIR=${D} BINDIR=/usr/bin install || die "make install failed"
+ make DESTDIR="${D}" BINDIR=/usr/bin install || die "make install failed"
}