summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild')
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild
index f63cedd3b33b..996004e9ec4e 100644
--- a/x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild
+++ b/x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild,v 1.5 2003/10/16 16:10:23 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.23-r1.ebuild,v 1.6 2004/01/04 18:36:48 aliz Exp $
# to make this work in KDE, run it with the -b option :)
S=${WORKDIR}/${P}
@@ -14,8 +14,12 @@ KEYWORDS="x86 sparc amd64"
DEPEND="=x11-libs/gtk+-1.2*"
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ sed -i -e "s/CFLAGS = -O3/CFLAGS = ${CFLAGS}/" Makefile
+}
+
src_compile() {
- sed -e "s/CFLAGS = -O3/CFLAGS = ${CFLAGS}/" Makefile | cat > Makefile
make || die
}