summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/rxvt/rxvt-2.7.8-r6.ebuild')
-rw-r--r--x11-terms/rxvt/rxvt-2.7.8-r6.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild b/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild
new file mode 100644
index 000000000000..f988007f4e2a
--- /dev/null
+++ b/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild,v 1.1 2003/03/20 09:06:54 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="rxvt -- nice small x11 terminal"
+SRC_URI="ftp://ftp.rxvt.org/pub/rxvt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc alpha sparc"
+IUSE="motif"
+HOMEPAGE="http://www.rxvt.org"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ motif? ( x11-libs/openmotif )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-security.patch
+
+ use motif && epatch ${FILESDIR}/${P}-azz4.diff
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-rxvt-scroll \
+ --enable-transparency \
+ --enable-xpm-background \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-mousewheel \
+ --enable-slipwheeling \
+ --enable-smart-resize \
+ --enable-menubar \
+ --enable-languages \
+ --enable-xim \
+ --enable-shared \
+ --enable-keepscrolling || die
+
+ emake || die
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ install || die
+
+ cd ${S}/doc
+ dodoc README* *.txt BUGS FAQ
+ dohtml *.html
+}