summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/windowmaker/files/0.92.0/windowmaker-0.92.0-math_h.patch')
-rw-r--r--x11-wm/windowmaker/files/0.92.0/windowmaker-0.92.0-math_h.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-wm/windowmaker/files/0.92.0/windowmaker-0.92.0-math_h.patch b/x11-wm/windowmaker/files/0.92.0/windowmaker-0.92.0-math_h.patch
new file mode 100644
index 000000000000..8c83d4da2c5c
--- /dev/null
+++ b/x11-wm/windowmaker/files/0.92.0/windowmaker-0.92.0-math_h.patch
@@ -0,0 +1,25 @@
+
+ Add a missing #include <math.h>.
+
+--- WindowMaker-0.92.0/configure.ac
++++ WindowMaker-0.92.0/configure.ac
+@@ -78,7 +78,8 @@
+ [ --with-incs-from pass compiler flags to look for header files],
+ [inc_search_path="$withval $inc_search_path"])
+
+-
++AC_CHECK_LIBM
++AC_SUBST([LIBM])
+
+ dnl Checks for library functions.
+ dnl ============================
+--- WindowMaker-0.92.0/src/placement.c
++++ WindowMaker-0.92.0/src/placement.c
+@@ -27,6 +27,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <limits.h>
++#include <math.h>
+
+ #include "WindowMaker.h"
+ #include "wcore.h"