summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/libxfcegui4/libxfcegui4-4.6.1-r1.ebuild')
-rw-r--r--xfce-base/libxfcegui4/libxfcegui4-4.6.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.6.1-r1.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..c5000f708bd3
--- /dev/null
+++ b/xfce-base/libxfcegui4/libxfcegui4-4.6.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/libxfcegui4-4.6.1-r1.ebuild,v 1.1 2009/07/16 03:53:59 darkside Exp $
+
+EAPI="1"
+
+inherit xfce4
+
+xfce4_core
+
+DESCRIPTION="Unified widgets library"
+HOMEPAGE="http://www.xfce.org/projects/libraries"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+LICENSE="LGPL-2"
+IUSE="debug doc glade startup-notification"
+
+RDEPEND="gnome-base/libglade
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ >=xfce-base/xfconf-${XFCE_VERSION}
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable doc gtk-doc) $(use_enable glade gladeui)"
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"