summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r3.ebuild')
-rw-r--r--xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r3.ebuild b/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r3.ebuild
new file mode 100644
index 000000000000..b8d8675095cb
--- /dev/null
+++ b/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r3.ebuild,v 1.1 2008/08/21 21:35:51 angelos Exp $
+
+inherit autotools eutils xfce44
+
+xfce44
+
+DESCRIPTION="Battery status panel plugin"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-util/pkgconfig
+ dev-util/intltool
+ dev-util/xfce4-dev-tools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-freebsd.patch \
+ "${FILESDIR}"/${P}-libacpi.patch \
+ "${FILESDIR}"/${P}-2.6.21.patch \
+ "${FILESDIR}"/${P}-2.6.24-headers.patch \
+ "${FILESDIR}"/${P}-sysfs.patch
+
+ sed -i -e "/^AC_INIT/s/battery_version()/battery_version/" configure.in
+ intltoolize --force --copy --automake || die "intltoolize failed."
+ AT_M4DIR=/usr/share/xfce4/dev-tools/m4macros eautoreconf
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+xfce44_goodies_panel_plugin